Articles in this section

Plesk Firewall cannot be activated: I did not receive connectivity confirmation after applying new firewall configuration

kb: technical firewall bug

Symptoms

  • Unable to activate Plesk Firewall in Tools & Settings > Firewall > Activate rules with:

    Unexpected token '<', "<html> <h"... is not valid JSON
    Failed to apply the firewall configuration.

    The firewall configuration has failed.
    I did not receive connectivity confirmation after applying new firewall configuration, then same happened after I reverted to previous configuration. This means that both new and previous configurations were bad. Emergency rollback to the configuration without rules was performed. Firewall is now disabled. Fix your rules and try again.

Cause

Plesk bug PPPM-14043 which will be fixed in future updates.

Resolution

Until this be fixed, as workaround:

  • Edit the Panel.ini to disable the synchronous task execution by adding the lines below:

    [task]
    syncExecution=false

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.