Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
The Plesk product license fails to update or a new license cannot be retrieved. One of the following errors is visible in the Plesk GUI:
PLESK_ERROR: Could not update the license. Make sure that connections to the license server ka.plesk.com on TCP port 443 are not blocked. See how to do so.
PLESK_ERROR: Licensing Server Unreachable: Unable to connect with licensing server.
Please make sure that your network allows communication to ka.plesk.com:5224.
For more details check system help pages.PLESK_ERROR: Couldn't resolve host name
PLESK_ERROR: Can't connect to ka.plesk.com:5224 (Timeout)
PLESK_ERROR: Could not update the license. Make sure that connections to the license server
ka.plesk.com
on TCP port 5224/443 are not blocked. See how to do so. -
The
curl ka.plesk.com:443
command fails with one of the following errors in/var/log/plesk/panel.log
:# cURL cannot communicate with license server https://id-X2.kaid.plesk.com:443/ (): Couldn't resolve host name(6)
# cURL cannot communicate with license server https://id-X2.kaid.plesk.com:443/ (195.214.233.80): Timeout was reached(28)
# cURL cannot communicate with license server https://id-X2.kaid.plesk.com:443/ (195.214.233.80): Couldn't connect to server(7)
# cURL cannot communicate with license server https://ka.plesk.com/xmlrpc (): Couldn't connect to server(7)
# cURL cannot communicate with license server https://ka.plesk.com/xmlrpc (): Couldn't resolve host name(6)
Cause
Plesk tries to connect to the license server ka.plesk.com on TCP ports 5224 or 443 to update the license, but it cannot establish a connection.
Since February 5, 2018, ka.plesk.com
hostname will be resolved into 3 (or more) different IP addresses based on round-robin logic:
CONFIG_TEXT: 195.214.233.80 (old one)
195.214.233.81 (new)
195.214.233.82 (new)
Additionally, since the same date, the Key Administrator will accept connections from Plesk on two ports :
CONFIG_TEXT: 5224 (an old port, non-standard at this point)
443 (new, default HTTPS port)
Resolution
1. Log into your server via SSH
2. Check whether ka.plesk.com resolves to one of the proper IP addresses:
# nslookup ka.plesk.com
Non-authoritative answer:
Name: ka.plesk.com
Address: 195.214.233.80
2. If it does not, check that the /etc/hosts
file has no custom records mentioning ka.plesk.com
while using your favorite command-line text editor and specify one of the IP addresses for ka.plesk.com
there, for example:
CONFIG_TEXT: 195.214.233.81 ka.plesk.com
3. Use the following command to check the outbound connectivity towards the Plesk licensing servers on port 443:
# telnet ka.plesk.com 443
In case a connection is successful, the output would be similar to the following:
# telnet ka.plesk.com 443
Trying 195.214.233.81...
Connected to ka.plesk.com.
Escape character is '^]'.
^]
In case a connection is not successful, you will receive empty output for a period over 60 seconds and you will eventually have to stop the command.
4. If ka.plesk.com
resolves to the right IP address, but the connection via telnet still fails, outgoing connections via port 443 are most likely blocked by either a local firewall, or an external firewall that resides on a level above the server.
Once you allow the outbound connections on port 443 successfully within all firewalls, the communication with the Plesk licensing servers will be successful and the errors will stop showing.
As a temporary workaround, you can upload a file with the license to the server and install it from a command line (the command is applicable for both Windows and Linux):
# plesk bin license -i path_to_license_file
1. Log into your server via RDP
2. Check whether ka.plesk.com resolves to one of the proper IP addresses by executing the following command in Command Prompt:
C:\> nslookup ka.plesk.com
Non-authoritative answer:
Name: ka.plesk.com
Address: 195.214.233.80
2. If it does not not, check that the C:\Windows\System32\drivers\etc\hosts
file has no custom records mentioning ka.plesk.com
with any text editor and specify one of the IP addresses for ka.plesk.com
there, for example:
CONFIG_TEXT: 195.214.233.81 ka.plesk.com
3. Use the following command to check the outbound connectivity towards the Plesk licensing servers on port 443:
Note: The telnet client should be installed additionally for Windows.
C:\> telnet ka.plesk.com 443
In case a connection is successful, the output would be similar to the following:
C:\> telnet ka.plesk.com 443
Trying 195.214.233.81...
Connected to ka.plesk.com.
Escape character is '^]'.
^]
In case a connection is not successful, you will receive empty output for a period over 60 seconds and you will eventually have to stop the command.
4. If ka.plesk.com
resolves to the right IP address, but the connection via telnet still fails, outgoing connections via port 443 are most likely blocked by either a local firewall, or an external firewall that resides on a level above the server.
Once you allow the outbound connections on port 443 successfully within all firewalls, the communication with the Plesk licensing servers will be successful and the errors will stop showing.
As a temporary workaround, you can upload a file with the license to the server and install it from a command line (the command is applicable for both Windows and Linux):
C:\> plesk bin license -i path_to_license_file
Comments
1 comment
We are about to renew our Plesk web hosting license for 178.20.144.166, it is giving that it will renew automatically but we need to renew it now, it is about to expire on 11feb 2024, and we don’t want any interruption, kindly advice how to renew manually or check from your side to renew it.
Please sign in to leave a comment.