Applicable to:
- Plesk for Linux
Symptoms
- Log Browser extension stuck in loading state
- After a while the Log Browser page becomes blank with an error in DevTools (F12):
CONFIG_TEXT: GET https://203.0.113.2:8443/modules/log-browser/index.php/api/read-log-list?page=999999999&items=1000&filterDateFrom=1659456000&filterDateTo=1659542399 504 (Gateway Time-out)
- With error in
/var/log/sw-cp-server/error_log
:
CONFIG_TEXT: [error] 6637#0: *6708 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 203.0.113.3, server: , request: "GET /modules/log-browser/index.php/api/read-log-list?page=999999999&items=1000&filterDateFrom=1659456000&filterDateTo=1659542399 HTTP/1.1", upstream: "fastcgi://unix:/var/run/sw-engine.sock", host: "203.0.113.2:8443", referrer: "https://203.0.113.2:8443/modules/log-browser/index.php/index/index"
Cause
Product issue:
-
#EXTPLESK-3898 "The extension now works faster because it retrieves only a fair number of log records instead of retrieving them all from the server."
Fixed in:- Log Browser 1.4.0 05 October 2022
Resolution
Workaround
If update is not possible for some reason you may try the following
As a temporary workaround increase the overall timeout values as explained in the article:
Additionally, the mail log file can be checked via ssh using the below command:
# tail -fn0 /var/log/maillog
Comments
0 comments
Please sign in to leave a comment.