Applicable to:
- Plesk for Linux
Symptoms
- Plesk Obsidian version is 18.0.81.2 or lower and GoAccess is in use for statistics
- Error when generating FTP statistics on a Linux Plesk server where the locale is set to something other than English
-
Plesk
panel.logwith debug enabled shows errors that are similar to the following:CONFIG_TEXT: [2026-10-06 06:38:56.727] 347020:6ac47b60b19f2 INFO [panel] == Begin Execute web-statistics statistics
[2026-10-06 06:38:56.778] 347020:6ac47b60b19f2 DEBUG [util_exec] [3b1e0e7af5692c00e968fbc5ad4adbad-0] Starting: web_statistic_executor --anonymize-ip
...
[2026-10-06 06:39:13.265] 347020:6ac47b60b19f2 DEBUG [util_exec] [3b1e0e7af5692c00e968fbc5ad4adbad-0] Finished in 16.48693s, Error code: 1
[2026-10-06 06:39:13.265] 347020:6ac47b60b19f2 ERR [util_exec] proc_close() failed ['/opt/psa/admin/bin/web_statistic_executor' '--anonymize-ip'] with exit code [1]
[2026-10-06 06:39:13.266] 347020:6ac47b60b19f2 ERR [panel] PleskUtilException: '/opt/psa/admin/bin/web_statistic_executor' '--anonymize-ip' failed with code 1. -
Running the
plesk sbin statistics --calculate-one --domain-name=example.comcommand manually results in errors such as the following:CONFIG_TEXT: stderr: ' [SETTING UP STORAGE -] {0} @ {0/s}
==471696== GoAccess - version 1.8.1 - Apr 14 2024 22:34:39
==471696== Config file: /etc/goaccess/goaccess.conf
==471696== https://goaccess.io - <hello@goaccess.io>
==471696== Released under the MIT License.
==471696==
==471696== FILE: /var/www/vhosts/system/example.com/logs/xferlog_regular.webstat
==471696== Analysé 1 lignes produisant les erreurs suivantes:
==471696==
==471696== Token 'Thu Oct 01' doesn't match specifier '%d'
==471696==
==471696== Erreurs de format - Vérifiez votre format de journal / date / heure
'
Cause
When a non-English locale is set for a domain-owning user (admin, reseller, customer), GoAccess is invoked with that locale, however FTP logs xferlog* are always with English dates, thus the error on processing such logs occurs.
This is a known Plesk bug with ID #PPPM-15549, which is expected to be resolved permanently with the release of Plesk Obsidian 18.0.82.
You may track the bug ID in the Change Log for Plesk Obsidian
Note: Please click the Follow button near the article headline to stay informed - you will receive an update via email when the bug is fixed
Resolution
Until the bug is fixed permanently, you may execute the following workaround:
1. Log into Plesk as the domain-owning user (admin, reseller or customer)
2. On the top right of your screen, press on the name of the user and select Edit Profile
3. Set the Plesk language to English
4. Press Apply
Comments
Please sign in to leave a comment.