Plesk 360
Platform 360
Symptoms
- Website is down in 360 Monitoring with "415 Unsupported Media Type" error.
- In fact, website works fine via a browser or cURL.
-
The next log entry can be found at Imunify 360 side:
"message": "Access denied by Imunify360 bot-protection. IPs used for automation should be whitelisted"
Cause
360 Monitoring user-agent is blocked by Imunify360.
Resolution
- Make sure that 360 Monitoring IPs are added to the Imunify360 Whitelist to prevent it from being greylisted.
- Log into 360 Monitoring dashboard.
- Add
Accept: text/htmlheader to Headers field inside affected website's settings at Websites > example.com > Settings > Show advanced options page. - Press Update button to apply changes.
Note: For updating several websites at once use How to change settings for multiple websites at once under 360 Monitoring? guide.
Comments
Could not find where to configure the header field,
and could not find anywhere to edit White List in Immunify360 ??
Marc Druilhe The provided instructions are for the 360 Monitoring interface and not WebPros Dashboard. Please let me explain that WebPros Dashboard is in the beta state means that not all the functionality is yet implemented. If you have observed "415 Unsupported Media Type" error under the WebPros Dashboard, please follow the next guide to switch back to 360 Monitoring interface: https://support.webpros.com/hc/en-us/articles/35144382234519
Once you switched back to 360 Monitoring UI then you can procced with the current article. To revert back to WebPros Dashboard interface, please press “Explore Now” button in 360 Monitoring UI.
Regarding the Imunify360 whitelist, please refer to their official documentation here: https://docs.imunify360.com/dashboard/#firewall
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