Articles in this section

Plesk Nextcloud extension deactivates users by constantly failing to log in

Plesk for Linux kb: technical ext: nextcloud

Applicable to:

  • Plesk for Linux

Symptoms

  • A user in a Nextcloud instance installed with the Plesk extension is constantly disabled after failed login attempts:

    {"reqId":"Z9H-9mvgHtjc1lzpK3Z-lwAAAE8",
    "level":2,"time":
    "2025-03-12T21:39:04+00:00",
    "remoteAddr":"203.0.113.2",
    "user":false,"app":
    "core","method":
    "GET","url":"/ds/ocs/v2.php/cloud/users/john.doe?format=json",
    "message":"Login failed: 'john.doe' (Remote IP: '203.0.113.2')",
    "userAgent":"Mozilla/5.0 (compatible; Nextcloud Plesk Extension/1.6.10; example.com)",
    "version":"31.0.0.18",
    "data":{"app":"core"},
    "id":"67d1ff0b5ec00"}

  • Auto login fails with the Plesk extension from Extensions > Nextcloud > Log in

Cause

The password was changed in Nextcloud, and Plesk can't retrieve it because it's encrypted. The scheduled task that refreshes the instance data in Plesk keeps trying to log in, and the user is disabled after too many failed tries.

Resolution

To stop this, update the password in Plesk to match the one in Nextcloud.

  1. Backup the extension's database

    # cp -a /usr/local/psa/var/modules/nextcloud/nextcloud.sqlite3{,.bak}

  2. Access the database

    # sqlite3 /usr/local/psa/var/modules/nextcloud/nextcloud.sqlite3

  3. Update the password for the Nextcloud user (replace updated_password with the current Nextcloud password)

    UPDATE instances SET ncPass='updated_password' WHERE ncUser='john.doe';

  4. Exit SQLite

    .quit

Vote to add a way to update the password using the Plesk extension: Add password change to Nextcloud extension

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.