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High CPU load on Plesk server caused by Log Browser extension

kb: bug Plesk for Linux kb: technical

Symptoms

  • There are processes with high CPU load related to the sw-engine service:

    CONFIG_TEXT: psaadm 27219 56.2 1.0 356796 87564 ? Rs 13:37 2:49 /usr/bin/sw-engine -c /opt/psa/admin/conf/php.ini /opt/psa/admin/plib/scripts/task-async-executor.php -task-id 4597

  • The Log Browser extension is installed.

  • There are many long-running tasks related to the Log Browser extension with the 'ext-log-browser-parse-maillog' type when checking using the following query:

    CONFIG_TEXT: plesk db "SELECT id,type,status,finishTime FROM longtasks WHERE status <> 'done'"

Cause

Plesk extension bug with ID EXTPLESK-5686. The bug was fixed in August, 2024.

Resolution

Update the Log Browser extension
As a workaround:

Workaround 1:

Edit panel.ini file, appending the following lines to it:

CONFIG_TEXT: [ext-log-browser]
mailQueue.customerAccess = false

Workaround 2:
  1. Connect to the server via SSH.

  2. Flush the journalctl logs, for example, based on size:

    # journalctl --vacuum-size=500M

    or based on time:

    # journalctl --vacuum-time=2d

  3. Re-enable the Log Browser extension:

    # plesk bin extension --disable log-browser && plesk bin extension --enable log-browser

Workaround 3:
  1. Connect to the server via SSH.

  2. Move the extension database file to another directory:

    # mv /usr/local/psa/var/modules/log-browser/log-browser.sqlite3 /root/log-browser.sqlite3_bak

  3. Run the extension utility as follows:

    # plesk bin extension --upgrade log-browser

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