Articles in this section

A .NET application does not work in Plesk on CloudLinux: dotnet: not found

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • Plesk is installed on CloudLinux OS.

  • When opening a .NET-based website in a web-browser, it fails to load.

  • The following error message appears in /var/log/passenger/passenger.log:

    CONFIG_TEXT: App 53089 output: /bin/sh: line 0: exec: dotnet: not found
    Could not spawn process for application /var/www/vhosts/example.com/httpdocs: The application process exited prematurely.

Cause

.NET software is being blocked by CageFS (part of CloudLinux Manager extension for Plesk).

Resolution

Solution I: Add dotnet packages into CageFS using the steps from this CloudLinux KB article:

To list all dotnetpackages, run the command:

# yum list installed | grep dotnet*

 

Solution II: Disable CageFS for the subscription system user at Plesk > CloudLinux Manager > Users tab.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.