Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Unable to connect Plesk server to Plesk 360 with the following errors which occur one after another:
Failed to generate screenshot of instance #1: cURL error 7: Failed to connect to shots.plesk.com port 443: Connection timed out (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://shots.plesk.com/api/v1/screenshot?cache=0&apiKey=UFS5XfbQ6887e52UG2ERcK8B6ESbnrwtV3D8z7yc&width=1024&height=768&url=https%3A%2F%2Fexample.com&product=WPT+Common&type=jpeg
-
There are one (or more) firewall blocks for the country of Ireland:
# ipconfig -L | grep -i IE
DROP all -- anywhere anywhere match-set plesk-ip4-IE src
DROP all -- anywhere anywhere match-set plesk-ip4-IE dst
Cause
IP address from shots.plesk.com is currently registered in Ireland and there is a drop rule set up in Plesk Firewall.
Resolution
- Log in to Plesk.
- Open Tools & Settings > Firewall.
- Choose one of the following:
- Disable the firewall rule(s) from that specific country (incoming and outgoing), or
- Allow the IP address 52.19.90.22 into the firewall and ensure that the allow rule comes before the drop rule(s).
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