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Unable to see backups in Acronis extension: An error has occurred. Please try again later or contact your administrator.

kb: bug kb: technical ext: acronis Plesk Obsidian for Linux

Applicable to:

  • Plesk for Linux

Symptoms

  • Unable to see backup in Acronis with the following error when going to Acronis > Backups:

    An error has occurred. Please try again later or contact your administrator.

  • The following errors show up in /var/log/plesk/panel.log when plesk debug mode is enabled:

    PHP Warning: file_get_contents(/mnt/Acronis/c999dec7-10000000002_0_17000000000_9/opt/psa/var/modules/acronis-backup/metadata.json): Failed to open stream: No such file or directory in /opt/psa/admin/plib/modules/acronis-backup/library/Common/Lib/Helpers/Utils.php on line 28

    ERR [extension/acronis-backup] Unable to read or parse metadata: Can not get content of the "/mnt/Acronis/c999dec7-10000000002_0_17000000000_9/opt/psa/var/modules/acronis-backup/metadata.json"

Cause

This was identified as a bug by Acronis with ID ABR-384180

Resolution

  1. Connect to the server via SSH

  2. Go to the following location with command:

    # cd /var/lib/Acronis/AgentCommData/

  3. Create a backup of post-capture-data.sh file with command:

    # cp -a post-capture-data.sh{,.bak}

  4. Use any text editor like vi to edit the post-capture-data.sh file as below:

    #echo "$(date -Ins) - Removing file with metadata ..." >> "$LOGFILE"
    #plesk bin extension --exec $EXTENSION_ID remove-meta.php' > diff.patch

    Note: Both lines above must to be commented

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