Articles in this section

Adding a local Git repository in Plesk fails: Request failed with status code 500

kb: technical ext: git

Symptoms

  • Adding a local Git repository at Domains > example.com > Git fails with the following error:

    Note: In earlier Plesk versions, a blank page was displayed instead.

  • This error is written in the Plesk panel log at /var/log/plesk/panel.log:

CONFIG_TEXT: [2024-04-23 11:37:04.097] 18375:66279d5f75cdc ERR [extension/git][] Unable add user to protected dir: Incorrect password: Your password is not complex enough. According to the server policy, the minimal password strength is Strong (recommended).

  • The minimum password strength at Tools & Settings > Security Policy was increased after the subscription was created.

Cause

The subscription system user was created before changing the Password strength security policy and as a consequence it's password does not satisfy the password strength requirements.

This is a Git extension bug with ID EXTGIT-241: Plesk shows a generic error instead of a clear message explaining the cause. It will be fixed in a future extrension updates.

Resolution

Reset the subscription system user to satisfy the current password strength policy:

  1. Log into Plesk
  2. Access Domains > example.com > Hosting & DNS > Hosting settings
  3. Scroll down to the System user's credentials and generate a new password that would match the policy
  4. Save the changes
  5. Proceed to Add the Git repository once again

Note: The system user password can also be used for FTP and SSH access to the subscription. Update it in any FTP/SSH clients or deployment tools that use these credentials.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.