Plesk for Linux
kb: technical
dns
Symptoms
- Tools & settings > DNS Templates > Apply DNS Template Changes > Apply the changes to all zones does not add new records to Domains > example.com > DNS settings with no error in UI.
- Records were customized/removed in Domains > example.com > DNS settings.
Cause
Records modified in the Tools & settings > DNS Templates are modified in the zone (if they were not changed by users before that).
Resolution
Restore DNS records for each domain or globally from command-line:
From UI for each domain:
- Log into Plesk,
- Click on Domains > example.com > DNS Settings > Reset to defaults.
From command-line for all domains:
-
Connect to the server via SSH.
-
Restore DNS Template for all domains:
# plesk db -N -e "select domains.name,IP_Addresses.ip_address from IP_Addresses,domains,dom_param where IP_Addresses.id = dom_param.val and domains.id = dom_param.dom_id and dom_param.param = 'ip_addr_id'" | while read domain ip; do plesk bin dns --reset $domain -ip $ip; done
Comments
0 comments
Please sign in to leave a comment.