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Could not update license. Make sure connections to ka.plesk.com license server on TCP port 443 are not blocked

Plesk for Linux kb: technical

Symptoms

Unable to install license:

PLESK_ERROR: Make sure connections to ka.plesk.com license server on TCP port 443 are not blocked

Cause

Unclear. ka,plesk.com is accessible from server. Unknown error appear in log:

# tail -fn0 /var/log/plesk/panel.log
[2022-03-18 09:58:34.334] 18447:623490082ef0c ERR [panel] KA Request Failure code: 2 Network failure
...
* Could not resolve host: id-00.kaid.plesk.com; Unknown error
* Closing connection 1

Resolution

Create 3rd-line before applying the solution

Plesk for Linux
  1. Connect to the server via SSH

  2. Restart Plesk services:

    # systemctl restart sw-engine && systemctl restart sw-cp-server

Plesk for Windows
  1. Connect to the server via RDP
  2. Start Plesk Services Monitor from the tray

  3. Select Plesk Management Service under the Plesk Run-Time section

  4. Click Restart

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Comments

2 comments
Date Votes
  • Still getting the error message

    0
  • This happens also if your server only has a IPv6 address.

    ka.plesk.com only has a A record for IPv4.

    0

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