Plesk for Linux
kb: technical
Symptoms
Unable to install license:
PLESK_ERROR: Make sure connections to ka.plesk.com license server on TCP port 443 are not blocked
Cause
Unclear. ka,plesk.com is accessible from server. Unknown error appear in log:
# tail -fn0 /var/log/plesk/panel.log
[2022-03-18 09:58:34.334] 18447:623490082ef0c ERR [panel] KA Request Failure code: 2 Network failure
...
* Could not resolve host: id-00.kaid.plesk.com; Unknown error
* Closing connection 1
Resolution
Create 3rd-line before applying the solution
Plesk for Linux
-
Connect to the server via SSH
-
Restart Plesk services:
# systemctl restart sw-engine && systemctl restart sw-cp-server
Plesk for Windows
- Connect to the server via RDP
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Start Plesk Services Monitor from the tray
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Select Plesk Management Service under the Plesk Run-Time section
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Click Restart
Comments
2 comments
Still getting the error message
This happens also if your server only has a IPv6 address.
ka.plesk.com only has a A record for IPv4.
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