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DKIM key not visible in How to configure external DNS section

kb: bug Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

  • Generating new signing keys and selecting them via the Active DKIM Selector in Plesk > Domains > example.com > Mail Settings is possible
  • After deactivating and reactivating DKIM spam protection in Plesk > Domains > example.com > Mail Settings, a new DKIM key is not visible in Plesk > Domains > example.com > Mail Settings > How to configure external DNS
  • The necessary keys are also not present in /etc/domainkeys/

Cause

The issue was confirmed as a bug with ID #PPPM-14160 DKIM key not visible and was resolved permanently in Plesk Obsidian version 18.0.57.

Resolution

Update Plesk Obsidian to version 18.0.57 by using the information in this article:

How to update Plesk Obsidian to the latest build?

Afterwards, go to Plesk > Domains > example.com > Mail Settings , uncheck the Use DKIM spam protection system to sign outgoing box, save the changes, check it and save the changes once again.

That should make the DKIM appear in Plesk > Domains > example.com > Mail Settings > How to configure external DNS.

Alternatively, if turning DKIM off and on again does not resolve the issue, you can manually create the keys using the following instructions:

# mkdir /etc/domainkeys/example.com
# cd /root
# openssl genrsa -out private.key 1024
# mv private.key /etc/domainkeys/example.com/default
# chmod 440 /etc/domainkeys/example.com/default
# chown root:pouser /etc/domainkeys/example.com/default
# cd /etc/domainkeys/example.com/
# openssl rsa -in default -pubout -out public.key
# openssl rsa -in /etc/domainkeys/example.com/default -pubout
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Comments

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Date Votes
  • The problem now is present in Plesk for Windows after updating to Plesk Obsidian 18.0.77

    We need you to check it.

    0

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