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Can't send email with Plesk Email Security installed: (!)DENIED ACCESS from IP 203.0.113.2, policy bank ''

kb: bug Plesk for Linux kb: technical ext: pes

Symptoms

Can't send email with Plesk Email Security installed after changing outgoing mail mode. This error is logged to /var/log/maillog:

CONFIG_TEXT: amavis[1547]: (!)DENIED ACCESS from IP 203.0.113.2, policy bank ''

Cause

Product issue with Plesk Email Security: EXTPLESK-8778; to be fixed in future releases of the extension.

The extension doesn't update the configuration when a new IP address is added, which leads to this error after switching the outgoing mail mode. 

Resolution

As a workaround, switch the debug mode in PES:

  1. Log in to Plesk
  2. Go to Tools & Settings > Plesk Email Security > Server Settings > Advanced > Debugging
  3. Change the value of the option Amavis log level to 1: args passed from client, some more interesting messages and click Save
  4. Change the value of the option Amavis log level back to the default 0: startup/exit/failure messages, viruses detected and click Save
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