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BitNinja fails to install license on Plesk: License type: inactive

kb: technical Plesk extension

Applicable to:

  • Plesk Obsidian for Linux

Symptoms

  • BitNinja fails to install the license with the following in Extensions > BitNinja > About BitNinja:

    CONFIG_TEXT: License type: inactive

  • The license is installed in Tools & Settings > License Information > Additional License Keys
  • There is the following error message at https://admin.bitninja.io/activate?partner=Plesk&license=RSK__PLESK__XXXXXXXX link:

    CONFIG_TEXT: License key cannot be connected to your account. Please, contact support

Cause

BitNinja agent was installed on the server previously with the license key of another account and the old license files are grabbed by the BitNinja agent.

Resolution

1. Connect to the server via SSH
2. Uninstall the extension with the commands below:

# plesk bin extension --uninstall bitninja-linux-agent

# apt-get purge 'bitninja*'

3. Remove the directories containing the information about the old license with the commands:

# rm -rf /var/lib/bitninja/

# rm -rf /etc/bitninja/

4. Reinstall the extension via the Plesk panel

5. Proceed with the steps in Extensions > BitNinja > Buy License! 

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