Symptoms
-
Extensions > Plesk Email Security > Install Now returns:
PLESK_ERROR: Access denied
-
The following error can be spotted in
/var/log/plesk/panel.log
when debug is enabled:CONFIG_TEXT: [2023-01-01 06:56:23.320] 35162:63b174e633218 ERR [panel] pm_Exception: Access denied
file: /usr/local/psa/admin/plib/modules/email-security/library/Component/Dovecot.php
line: 227
code: 0
trace: #0 /usr/local/psa/admin/plib/modules/email-security/library/Component/Dovecot.php(240): PleskExt\EmailSecurity\Component\Dovecot::mailDir(string 'johndoe@example.com')
Cause
Mailbox johndoe@example.com still exists in SpamAssassin database but it does not exist in Domains > example.com > Mail > Email Addresses
# plesk db "select * from spamfilter;"
+----+--------------------------------+---------------+-------------+
| id | username | serviceNodeId | preferences |
+----+--------------------------------+---------------+-------------+
| 1 | @ | 1 | true |
| 2 | johndoe@example.com | 1 | true |
Resolution
- Log into Plesk
- Re-create johndoe@example.com in Domains > example.com > Mail > Email Addresses
- Install Plesk Email Security in Extensions > Plesk Email Security > Install Now
- Remove johndoe@example.com in Domains > example.com > Mail > Email Addresses
Comments
0 comments
Please sign in to leave a comment.