Plesk for Linux
kb: technical
Symptoms
The Log Browser extension in Plesk provides no entries in the Mail tab despite the fact that there are entries in /var/log/syslog and /var/log/maillog.
Cause
The Log Browser extension retrieves information from the output of journald. On this server, journald is not configured to store data persistently, so the output for mail services is empty:
# journalctl -u postfix No journal files were found. -- No entries -- # journalctl -u dovecot No journal files were found. -- No entries --
Resolution
Note: Restarting the journal service may briefly interrupt system log collection.
- Connect to the server via SSH.
-
Open the
journaldconfiguration file for editing:nano /etc/systemd/journald.conf
-
Ensure the
Storageparameter is set topersistentunder the[Journal]section (uncomment the line if necessary):[Journal] Storage=persistent
- Save the changes (Ctrl+O, Enter) and exit the editor (Ctrl+X).
-
Restart the journal service to apply changes:
systemctl restart systemd-journald
-
Restart the mail services to ensure they reconnect to the journaling socket:
systemctl restart postfix dovecot
Comments
Please sign in to leave a comment.