Applicable to:
- Plesk for Windows
Symptoms
-
When accessing Plesk, the following error appears in a browser:
CONFIG_TEXT: Service Unavailable.
HTTP Error 503. The service is unavailable. -
The
PleskControlPanel
application pool at IIS Manager > hostname > Application Pools is stopped. After starting it manually, the application pool stops on the next attempt to open Plesk in a browser. -
The following error messages appear in the Event Viewer > Windows Logs > Application:
CONFIG_TEXT: The worker process for application pool 'PleskControlPanel' encountered an error
'Cannot read configuration file due to insufficient permissions
' trying to read configuration data from file '?\C:\inetpub\temp\apppools\PleskControlPanel\PleskControlPanel.config', line number '0'.
The data field contains the error code. -
The following articles do not solve the issue Plesk for Windows Server shows 503 Service Unavailable: Cannot read configuration file or How to reconfigure the PleskControlPanel website in IIS
Cause
Lack of permissions for the psaadm user for C:\Inetpub\temp
location.
Resolution
-
Connect to a Plesk server via RDP.
-
On Windows Explorer, right-click on
C:\Inetpub\temp
; -
Go to Properties > Security (tab) > Advanced >select psaadm > click on Edit;
-
Make sure that its NTFS permissions are set as follows:
Note: In case there is an explicit Deny enabled for the psaadm user or it is inherited, remove it and disable inheritance.
- Start the
PleskControlPanel
application pool at IIS Manager > hostname > Application Pools;
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