Articles in this section

Plesk for Windows Server shows 503 Service Unavailable: Cannot read configuration file

Plesk for Windows kb: technical ABT: Group B

Applicable to:

  • Plesk for Windows

Symptoms

  • When accessing Plesk, the following error appears in a browser:

    PLESK_INFO: Service Unavailable.
    HTTP Error 503. The service is unavailable.

  • The "PleskControlPanel" application pool at IIS Manager > SERVERNAME > Application Pools is stopped. After starting it manually, the application pool stops on the next attempt to open Plesk in a browser.

  • The following error message appears in the Event Viewer Application log (Windows Logs):

    PLESK_INFO: The worker process for application pool 'PleskControlPanel' encountered an error
    'Cannot read configuration file due to insufficient permissions
    ' trying to read configuration data from file '?\C:\inetpub\temp\apppools\PleskControlPanel\PleskControlPanel.config', line number '0'.
    The data field contains the error code.


    PLESK_INFO: The worker process for application pool 'PleskControlPanel' encountered an error
    'Cannot read configuration file
    ' trying to read configuration data from file '\\?\<EMPTY>', line number '0'.
    The data field contains the error code.

Cause

Plesk configuration file PleskControlPanel.config located at C:\inetpub\temp\appPools\PleskControlPanel is corrupted.

Resolution

  1. Connect to the Plesk server via RDP.

  2. Rename the PleskControlPanel.config file located at C:\inetpub\temp\appPools\PleskControlPanel. This file will be automatically generated on the next attempt to open Plesk.

  3. Start Plesk Reconfigurator at Windows Start > All Programs > Plesk.

  4. In Plesk Reconfigurator, click Repair Plesk Installation > select Check Plesk Services > click Check.

  5. Restart IIS using the following command in a command prompt:

    C:\> iisreset /restart

  6. Open Plesk in a web-bowser.
Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.