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WordPress can not be installed via WP Toolkit in Plesk: Specified column "guid" is not in the row

Plesk for Windows Plesk for Linux kb: technical ext: wptk ABT: Group B

Applicable to:

  • Plesk for Windows
  • Plesk for Linux

Symptoms

  • It is not possible to install WordPress via WP Toolkit with the error:

    PLESK_ERROR: Specified column "guid" is not in the row

  • The same error can be found in the file /var/log/plesk/panel.log:

    CONFIG_TEXT: ERR [panel] Zend_Db_Table_Row_Exception: Specified column "guid" is not in the row

  • When updating or reinstalling an existing WordPress instance with WP Toolkit, a similar error to the following is written to /var/log/plesk/panel.log:

    CONFIG_TEXT: DEBUG [extension/wp-toolkit] Exception: Database migration has failed. Log of phinx:
    Phinx by CakePHP - https://phinx.org. 0.11.1

    using config file ./usr/local/psa/admin/plib/modules/wp-toolkit/library/Db/phinx.php
    using config parser PHP
    using migration paths
    - /usr/local/psa/admin/plib/modules/wp-toolkit/library/Db/Migrations
    warning no environment specified, defaulting to: production
    using adapter sqlite
    using database /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3

    == 20190517060827 ChangeColumnsDefinitionToCorrect: migrating
    PDOException: SQLSTATE[HY000]: General error: 11 database disk image is malformed in /usr/local/psa/admin/plib/modules/wp-toolkit/vendor/robmorgan/phinx/src/Phinx/Db/Adapter/PdoAdapter.php:168

Cause

Corrupted WP Toolkit SQLite database.

Resolution

Add missing column to WP Toolkit database:

For Plesk Linux
  1. Connect to the server via SSH

  2. Create a backup of the SQLite3 database:

    # cp /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3.bak

  3. Access the SQLite3 database:

    # sqlite3 /usr/local/psa/var/modules/wp-toolkit/wp-toolkit.sqlite3

  4. Update the table Instances

    # sqlite> ALTER TABLE Instances ADD COLUMN guid VARCHAR(36) NULL;

  5. Disconnect from the SQLite database:

    # sqlite> .q

For Plesk Windows
  1. Connect to the server via RDP

  2. Create a backup of the original database at %plesk_dir%\var\modules\wp\-toolkit\wp-toolkit.sqlite3

  3. Open a command-line window and access the database using the SQLite3 utility with the following command:

    C:\> "%plesk_bin%\sqlite3" "%plesk_dir%\var\modules\wp-toolkit\wp-toolkit.sqlite3"

  4. Update the table Instances:

    C:\> sqlite> ALTER TABLE Instances ADD COLUMN `guid` VARCHAR(36) NULL;

  5. Disconnect from the SQLite database:

    C:\> sqlite> .q

Note: In case the resolution above does not fix the issue remove the extension WP Toolkit and install it again.

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