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Server with Plesk Email Security no longer sends/receives emails: [127.0.0.1]:10024: Connection refused

kb: bug ext: pes Plesk Obsidian for Linux ABT: Group B

Applicable to:

  • Plesk Obsidian for Linux

Symptoms

  • Server with Plesk Email Security no longer sends/receives emails

  • Emails remain in the mail-queue at Tools & Settings > Mail Server Settings > Mail Queue

  • Plesk Email Security was recently updated to version 1.1.1-223 as per Tools & Settings > Action log:

    CONFIG_TEXT: 'Upgrade extension' ('Extension Id': 'email-security' => 'email-security', 'Extension Name': 'Plesk Email Security' => 'Plesk Email Security', 'Extension Release': '216' => '223', 'Extension Version': '1.1.0' => '1.1.1')

  • In mailserver logs under /var/log/maillog the below message also can be found:

    CONFIG_TEXT: Aug 5 15:50:37 server postfix/error[5528]: A898A3FEA9: to=jdoe@example.com, relay=none, delay=0.19, delays=0.18/0.01/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

Cause

Product issue:

  • #EXTCERT-3028 "Postfix strict rules are not applied automatically and are removed in the update process"
    Fixed in:

Resolution

  1. Update Plesk Email Security extension.

  2. Open the extension to install the required components by going to Extensions > My Extensions > Plesk Email Security>Install

  3. Connect to the server via SSH

  4. Re-queue emails:

    # postsuper -r ALL

If the same issue exists but another steps are needed to fix the issue, for example re-install PES extension then create a new article. Most probably it has another cause that should be found.

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