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Seafile/Mattermost/Collabora cannot be accessed in Plesk: is enabled but not reachable for this domain

Plesk for Linux kb: technical ext: kolab

Applicable to:

  • Plesk for Linux

Symptoms

  • Plesk Premium Email (Kolab) Troubleshooting tab in Plesk UI shows:

    CONFIG_TEXT: Seafile is enabled but not reachable for this domain;
    Mattermost is enabled but not reachable for this domain;
    Collabora is enabled but not reachable for this domain;

    mceclip1.png

  • Address Book in webmail is empty, it does not show any contacts; 
  • Accessing Seafile in Extensions > My Extensions > Plesk Premium Email - Powered by Kolab shows error:

    CONFIG_TEXT: Authentication failure for Seafile Storage

  • Accessing Mattermost in Extensions > My Extensions > Plesk Premium Email - Powered by Kolab menu shows:

    CONFIG_TEXT: 404 not found

Cause

Nginx is not installed or is not enabled on the server:

In Tools & Settings > Services Management Reverse Proxy Server (nginx) is marked as:

  • Service is not installed
    or 
  • Service is not running

the same can be checked using:

# plesk bin extension -e kolab troubleshoot.php > report.txt | cat
array (
'code' => 1,
'stdout' => '',
'stderr' => 'Error: Nginx component is not installed.
',
)

Resolution

  1. Log into Plesk.
  2. Install or enable Nginx:
    In case Reverse Proxy Server (nginx) is marked as Service is not installed
    install it in Tools & Settings > Updates >Add/remove components page (Web hosting >Nginx web server and reverse proxy server menu)
    In case Reverse Proxy Server (nginx) is marked as Service is not running
    enable it by clicking Start the Service:
    mceclip0.png
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