Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
WP Toolkit fails to Smart Update a WordPress site on Plesk:
Smart Update test run could not be performed due to errors. Address the errors and try running Smart Update again.
Smart Update was unable to correctly clone your website for further analysis. Please try again later. -
Debug logs show the process fails because of a redirection:
DEBUG [extension/wp-toolkit] What broke when cloning WordPress instance #1 ('https://example.com'):
Page relative uri: /index.php/photo-gallery/
pageTitle 'example'
shortcode PleskExt\WpToolkit\SmartUpdates\Model\ShortcodeList::__set_state(array( PleskExt\WpToolkit\SmartUpdates\Model\ShortcodeList::__set_state(array(
'values' => 'values' =>
array ( array (
), 0 => '[nggallery id=1]',
'names' => ),
array ( 'names' =>
), array (
)) 0 => 'nggallery',
),
)) -
The website has the plugin Redirection
Cause
WP Toolkit product issue with ID EXTWPTOOLK-7655. This will be fixed in future updates to the extension.
Resolution
While the fix is released, the following workarounds will allow the Smart Update process to complete.
The Smart Update sitemap can be created and uploaded manually to let the rest of the process to continue.
-
Create and download a sitemap at xml-sitemaps.com with the site's URL (e.g. https://example.com)
-
Rename it
smart-update-sitemap.xml
-
Log in to Plesk
-
Go to Domains > example.com > File Manager > httpdocs
Note:
httpdocs
is the default document root and may vary; enter the one set in Domains > example.com > Hosting -
Press Upload and select
smart-update-sitemap.xml
This will remove the redirection that prevents Smart Update from creating a sitemap automatically.
- Go to WP Toolkit > example.com > Plugins
- Disable the plugin Redirection
The initial check can be disabled to ignore the error and update anyway.
-
Add this directive to it:
[ext-wp-toolkit]
smartUpdateInitialCheckEnabled = false
Comments
0 comments
Please sign in to leave a comment.