Applicable to:
- Plesk for Linux
Symptoms
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Emails sent through a mailing list (mailman) to external mailboxes (Gmail, Outlook, Yahoo!, etc.) are not received
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One of the following error messages appears in
/var/log/maillog
:NOQUEUE: reject: RCPT from localhost[::1]: 454 4.7.1 list@example.com: Relay access denied;
from=list@example.com to=john_doe@example.net proto=ESMTP helo=<mail.example.com>
NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.7.1
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One of the following error messages appears in
/var/log/mailman/smtp-failure
:delivery to list@example.com failed with code -1: Server not connected
delivery to john_doe@example.com failed with code -1: [Errno 104] Connection reset by peer
delivery to john_doe@example.com failed with code 553: sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
Cause
The localhost IPv4 and IPv6 addresses are not whitelisted.
Resolution
Add localhost IPv4 127.0.0.1 and IPv6 ::1/128 addresses to the white list:
Note: By applying the following solution, the limits on outgoing mail will not work.
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Go to Tools & Settings > Mail Server Settings > White List
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Click Add Network > add 127.0.0.1 to the IP address/mask field > click OK
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Click Add Network > add ::1/128 to the IP address/mask field > click OK
In case the records exist already, apply the solution Mailman does not send emails on a Plesk server with whitelisted IPv4 and IPv6 localhost addresses: Relay access denied
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