Plesk for Linux
kb: technical
Applicable to:
- Plesk for Linux
Symptoms
- It is not possible to receive a message only from a specific domain (that uses an an external mail server) to a specific mailbox on a Plesk-hosted domain.
- Other mailboxes of the same domain are able to receive messages from other external mail servers and domains.
- It is possible to send messages between affected mailboxes on the Plesk server.
Cause
Such behavior can be observed for a variety of reasons, due to which several things need to be checked.
Resolution
What can be checked:
- Check if the messages were not rejected or deferred on the Plesk server for some reason. This can be done in one of the following ways:
- Via Tools & Settings > Log Browser > Mail menu
- Via Tools & Settings > Mail Queue menu
- Manually, by checking the
/var/log/maillogfile (via SSH)
- Check if the messages have not arrived within the Spam and Trash (also known as Junk) folders of the affected mailbox.
- Check if the affected mailbox doesn't have any sieve filtering rules which are removing the messages. It can be done via Roundcube webmail, in Settings > Filters menu. Additionally, if the mailbox is accessed via a mail client (such as Thunderbird, Outlook etc.), it is worth checking if the client itself does not have any sorting or filtering rules.
- Check if the Plesk domain or server IP addresses are not blacklisted. It can be done with resources like DNSChecker.org or MXToolbox.
- If all the above doesn't give any information, the most likely scenario is that the email itself has not reached the Plesk server at all and is most likely blocked somewhere between the sending mail server and your server. In such a situation, you should consider contacting the administrator or postmaster of the sender domain in order to investigate the track where exactly the email is blocked on that end.
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