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Integrating SmarterMail 100.0.9560 with Plesk fails: Login failure: Missing auth

Plesk for Windows kb: technical

Symptoms

Plesk integration with SmarterMail 100.0.9560 (either local or remote, and either newly installed or existing one, already connected to Plesk and updated) fails or gets broken:

  • in Plesk in Tools & Settings > Server Components next to Mail Server:
    • attempt to connect newly installed SmarterMail does not result in any error, but SmarterMail is still shown as (not configured).
    • already installed SmarterMail started to be shown as (not configured).
  • The following error can be found upon attempting to update mailboxes in Plesk, as well as in the registry in HKLM\SOFTWARE\Wow6432Node\PLESK\PSA Config\Config\Packages\mailserver\smartermail:

    PLESK_ERROR: Error: mailmng failed: Login failure: Missing auth

    PLESK_ERROR: Error: Unable to update the mail account properties: mailmng failed: Login failure: Missing auth

Cause

Starting with SmarterMail 100.0.9560, the previously publicly accessible REST API endpoint:
/api/v1/licensing/about now requires authentication.
Earlier versions allowed this method to be queried without authentication.

Bug PPPM-15326 was created to address the issue from the Plesk side.

The bug was fixed in Plesk Obsidian 18.0.76 Update 3.

Resolution

Update Plesk to Obsidian 18.0.76 Update 3:

original solution - w/a

  1. Download and install (over already installed SmarterMail) the custom SmarterMail update released by the SmarterMail team: https://downloads.smartertools.com/smartermail/custom/100.0.9565.28700/smartermail_9565.exe.

    Warning: It is a custom, not regular, SmarterMail update. For clarifying the compatibility of that update with further regular SmarterMail updates, please reach out to the SmarterMail team.

  2. Restore the Plesk-SmarterMail connection in Plesk in Tools & Settings > Server Components > Mail Server.
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Comments

5 comments
Date Votes
  • While awaiting the update, the integration was completely affected.

    0
  • we're too waiting for an update. 8 Plesk servers all unable to connect to their mailboxes.

    will the fix be this week? if not i'll force a downgrade of smartermail.

    0
  • I have a Windows Plesk server that connects to another server using Remote SmarterMail. The problem is that SmarterMail has over 20,000 accounts, but I'll wait a little longer for the update.

    1
  • there is now a workaround from smartertools as they have a custom build available to install.  We just installed it and it now works.

    the url is: https://downloads.smartertools.com/smartermail/custom/100.0.9565.28700/smartermail_9565.exe 

    1
  • I appreciate the publication of this report and the confirmation that a solution is being worked on. Like other users, our integration has been completely affected following the update to Build 9560, which currently prevents any mailbox management. We look forward to the extension update to restore service as soon as possible. Thank you for your efforts!

    0

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