Articles in this section

Unable to install plugin in WordPress: HTTP Error 500.0 - Internal Server Error

Plesk for Windows kb: technical ABT: Group B

Applicable to:

  • Plesk for Windows

Symptoms

Unable to install plugin in Wordpress (for example, WooCommerce or Yoast SEO ) with one of the following errors:

CONFIG_TEXT: Installation failed: Could not copy file. woocommerce/dummy-data/dummy-variations.csv

CONFIG_TEXT: Installation failed: Internal Server Error

CONFIG_TEXT: Installation failed: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
IIS 8.5 Detailed Error - 500.0 - Internal Server Error
...
--> HTTP Error 500.0 - Internal Server Error C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP54\php-cgi.exe - The FastCGI process exceeded configured request timeout Most likely causes:
IIS received the request; however, an internal error occurred during the processing of the request.
...

CONFIG_TEXT: Installation failed: 500 Internal Server Error <!--[if lte IE 6]><![endif]--> Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error. More information about this error may be available in the server error log.

Cause

PHP requirements for the WordPress plugin are not met.

Resolution

Tune PHP settings for a domain according to the WordPress plugin requirements:

  1. Log in to Plesk GUI

  2. Go to Domains > example.com > PHP Settings

  3. Enable custom FastCGI settings

  4. Increase activityTimeout according to the plugin requirements, for example, to 120 and apply changes.

    Note: Another limit may need to be adjusted: requestTimeout. The default value for activityTimeout is 70. The default value for requestTimeout is 90. These are taken from IIS default values. To learn more about those limits, click here.

  5. If the issue is still reproduced, increase the values from the previous step.

  6. In case values were adjusted to a reasonable value but the issue persists, consider one of the following options:

    • Change PHP version
    • Contact WordPress plugin developer and customize PHP settings according to WordPress plugin requirements
    • Disable WordPress plugin
Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.