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Emails that are sent locally inside the server are rejected with "DMARC: REJECT message" or "DMARC: message moved to QUARANTINE"

kb: bug Plesk for Linux ABT: Group B

Applicable to:

  • Plesk for Linux

Symptoms

  • Emails that are sent locally on the server, for example from Plesk administrator, local domains, or web forms, are rejected or moved to the Spam folder.
  • The following records can be found in /var/log/maillog:

    CONFIG_TEXT: dmarc[15768]: Starting the dmarc filter...
    dmarc[15768]: DMARC: REJECT message for john.doe@example.com
    postfix-local[15764]: message discarded by a mail handler

    CONFIG_TEXT: dk_check[15713]: Starting the dk_check filter...
    dk_check[15713]: DKIM verify result: DKIM Feed: No signature
    dmarc[15714]: Starting the dmarc filter...
    dmarc[15714]: SPF record was not found in Authentication-Results:
    dovecot: service=lda, user=john.doe@example.com, ip=[], msgid=<20191029070309.A4B6925F@ns1.example.com>: saved mail to INBOX.Spam
    dmarc[15714]: DMARC: message moved to QUARANTINE for john.doe@example.com
    postfix-local[15648]: message discarded by a mail handler

  • The recipient domain has a DMARC policy set to p=quarantine or p=reject at Domains > example.com > DNS Settings.

    CONFIG_TEXT: _dmarc.example.com. TXT v=DMARC1; p=quarantine

Cause

This behavior was caused by product issue PPPM-7190. The issue will be fixed in Plesk Obsidian 18.0.79.

Resolution

Update Plesk to version 18.0.79 or later.

If the issue persists after the update, contact Plesk Support with more information.

If a similar report is received on Plesk Obsidian 18.0.79 or later, create a new PPS request to verify whether it is the same behavior that was expected to be fixed by PPPM-7190 or a new issue.

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Comments

10 comments
Date Votes
  • The first workaround does not work.

    I even restarted the server, but email is still sent to the spam box (spamassassin reports score=-0.0 autolearn=ham).

    Plesk Obsidian 18.0.52, CentOS Linux 7.9.2009

    0
  • Tried both workarounds, neither worked!!

    dk_check. DKIM Feed: No signature

    dmarc SPF record was not found in Authentication-Results

    This is childish that this is still a problem!

     

    0
  • doesnt work, we deactivated DMARC and SPF. i hope they fix this BUG fast

    0
  • Regarding Google and Yahoo's announcements that bulk senders must have DMARC in place at beginning of February 2024, it would be nice to have this bug fixed (as it is known since 2017 !?)

    0
  • Same problem, solution is not working. Plese fix the DMART whitelist config file

    /etc/psa/dmarc.conf

    0
  • Does this issue/bug still exist in the latest version of Plesk for Linux?  If so, what are the conditions necessary for the bug to present itself?  Does the bug only occur if the affected internal domain has misconfigured DMARC?

    0
  • Although there is a work-around, is this bug still present? Do I still have to edit that file?

    0
  • After so many years (!!) it's simply frustrating that we're still negotiating a workaround…

    It took years of work in the community to even get this acknowledged as a bug by Plesk. 

    But for Plesk, it seems to still be working as expected. At best, we will be subjected to another training session on DMARC by Plesk.

    In my case, my clients and I receive hundreds of these dmarc=faul mails daily. Totally professional.

    1

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