Applicable to:
- Plesk for Linux
Symptoms
-
Emails that are sent locally inside the server (emails from Plesk administrator, local domains or web forms) are rejected or moved to the spam folder with the following records in
/var/log/maillog
:CONFIG_TEXT: dmarc[15768]: Starting the dmarc filter...
dmarc[15768]: DMARC: REJECT message for john_doe@example.com
postfix-local[15764]: message discarded by a mail handler
CONFIG_TEXT: dk_check[15713]: Starting the dk_check filter...
dk_check[15713]: DKIM verify result: DKIM Feed: No signature
dmarc[15714]: Starting the dmarc filter...
dmarc[15714]: SPF record was not found in Authentication-Results:
dovecot: service=lda, user=john_doe@example.com, ip=[]. msgid=[20191029070309.A4B6925F@ns1.example.com]: saved mail to INBOX.Spam
dmarc[15714]: DMARC: message moved to QUARANTINE for john_doe@example.com
postfix-local[15648]: message discarded by a mail handler -
The DMARC policy is set as "p=quarantine" (treat with suspicion) or "p=reject" (block outright) in Plesk at Domains > example.com > DNS Settings.
PLESK_INFO: _dmarc.example.com. TXT v=DMARC1; p=quarantine
Cause
This is a Plesk bug with ID PPPM-7190, which is planned to be fixed in future product updates.
Resolution
Apply one of the following workarounds:
Workaround I
-
Check the "Return-Path" value from the email header which was moved to spam:
CONFIG_TEXT: Return-Path: <mail@example.com>
-
Connect to the Plesk server via SSH.
-
Whitelist the domain from "Return-Path" by adding its name to the "IgnoreMailFrom" string in the file
/etc/psa/dmarc.conf
:3.1. Create the file
/etc/psa/dmarc.conf
:# touch /etc/psa/dmarc.conf
3.2. Open the file in a text editor. In this example, we are using the vi editor:
# vi /etc/psa/dmarc.conf
3.3. Add the required domains as a line after 'IgnoreMailFrom':
Note: Replace example.com with actual domain name(s).
CONFIG_TEXT: IgnoreMailFrom example.com, example.net, example.org
In some unclear cases, the domain name should be added in uppercase letters, see #3094853.4. Save the changes and close the file.
Workaround II
Modify the DMARC record of the recipient domain: Change "p=quarantine" or "p=reject" to "p=none" at Domains > example.com > DNS Settings.
Comments
6 comments
The first workaround does not work.
I even restarted the server, but email is still sent to the spam box (spamassassin reports score=-0.0 autolearn=ham).
Plesk Obsidian 18.0.52, CentOS Linux 7.9.2009
Tried both workarounds, neither worked!!
dk_check. DKIM Feed: No signature
dmarc SPF record was not found in Authentication-Results
This is childish that this is still a problem!
doesnt work, we deactivated DMARC and SPF. i hope they fix this BUG fast
Regarding Google and Yahoo's announcements that bulk senders must have DMARC in place at beginning of February 2024, it would be nice to have this bug fixed (as it is known since 2017 !?)
Same problem, solution is not working. Plese fix the DMART whitelist config file
/etc/psa/dmarc.conf
Does this issue/bug still exist in the latest version of Plesk for Linux? If so, what are the conditions necessary for the bug to present itself? Does the bug only occur if the affected internal domain has misconfigured DMARC?
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