Applicable to:
- Plesk for Windows
Symptoms
-
DNS zones served by BIND DNS server on Plesk for Windows are not synced with the slave DNS servers configured either via Slave DNS Manager extension or manually with slave DNS server IP addresses added to Transfer Restrictions Template in Tools & Settings > DNS Settings.
-
The file
%plesk_dir%dns\etc\named.conf
does not have IP addresses added to Transfer Restrictions Template:CONFIG_TEXT: acl common-allow-transfer {
none;
}; -
If BIND is used on slave DNS server with info logging enabled, the following error is found on it:
CONFIG_TEXT: general: info: zone example.com/IN: Transfer started.
xfer-in: info: transfer of 'example.com/IN' from 203.0.113.2#53: connected using 192.0.2.2#35633
xfer-in: error: transfer of 'example.com/IN' from 203.0.113.2#53: failed while receiving responses: REFUSED
xfer-in: info: transfer of 'example.com/IN' from 10.39.5.12#53: Transfer completed: 0 messages, 0 records, 0 bytes, 0.001 secs (0 bytes/sec)
Cause
Plesk bug PPPM-7520.
Resolution
Until the bug is fixed, use the workaround:
-
Connect to the server using RDP.
-
Execute the following command to add slave DNS servers IP(s) to the Plesk database:
C:\> plesk db "REPLACE INTO misc VALUES ('DNS_Allow_Transfer0', '192.0.2.2');"
Note: The second value in the query is the slave DNS server IP address. It must be the same as in Extensions > My Extensions > Slave DNS Manager or in Tools & Settings > DNS Settings > Transfer Restrictions Template.
Note: multiple slave servers can be specified divided by a semicolon:
REPLACE INTO misc VALUES ('DNS_Allow_Transfer0', '192.0.2.2; 192.0.2.3');
-
Repair DNS configuration to add slave DNS servers IPs to the BIND configuration:
C:\> plesk repair dns -y
-
(only if Slave DNS Manager extension is used) Log in to Plesk.
-
(only if Slave DNS Manager extension is used) Go to Extensions > My Extensions > Slave DNS Manager, select slave DNS server and click Resync.
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