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Unable to upload files via Seafile interface on Plesk server: Unknown error, Authentication failed for seafile storage

Plesk for Linux ext: kolab

Applicable to:

  • Plesk for Linux

Symptoms

  • File upload via Seafile interface fails with:

    PLESK_INFO: Unknown error

  • When opening Seafile storage in the Plesk Premium Email webmail, one of the following error messages appear:

    PLESK_INFO: Authentication failed for seafile storage


    PLESK_INFO: User credentials not provided

  • The following error is displayed in the menu Plesk Premium Email > example.com > Troubleshooting:

    PLESK_WARN: Preferred domain redirects are not supported and will break various features.

    1247.jpg

Cause

This is a Seafile limitation - it may not work correctly when the website is using www redirection (configured in Plesk at Domains > example.com > Hosting Settings).

It will be resolved on future Seafile updates.
The next version of the Plesk Premium Email extension will warn about this limitation.

Resolution

  1. Log in to Plesk.

  2. Go to Domains > example.com > Hosting & DNS > Hosting Settings.

  3. Set the Preferred domain to None and click OK or Apply at the bottom of the page to apply the change.

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