Articles in this section

Plesk shows the error: PleskPermissionDeniedException: Session token has expired.

Plesk for Windows Plesk for Linux kb: technical ABT: Group A

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • One of the following error messages appear in Plesk:

    PLESK_ERROR: Error in Plesk: Zend_Controller_Exception: Session token has expired.


    PLESK_ERROR: Zend_Controller_Exception: Permission denied.#0


    PLESK_ERROR: PleskPermissionDeniedException: Session token has expired.


    PLESK_ERROR: Suddenly Unexpected token < in JSON at position 0

  • The following message is logged in Plesk log file /var/log/plesk/panel.log:

    # grep 'protection token check' /var/log/plesk/panel.log

    ERR [panel] Forgery protection token check failed.

Cause

Sessions time for forgery protection token has exceeded.

Resolution

 

For Plesk on Linux

 

  1. Connect to the Plesk server via SSH.

  2. If there is a stuck process in Plesk, cancel it.

  3. Increase PHP timeout in Plesk configuration file:

    # echo "session.gc_maxlifetime=86400" >> /usr/local/psa/admin/conf/php.ini

  4. Restart the Plesk service:

    # service sw-engine restart

 

For Plesk on Windows Server

 

  1. Connect to the Plesk server via RDP.

  2. If there is a stuck process in Plesk, cancel it.

  3. Open the file php.ini located in %plesk_dir%admin\conf.

  4. Increase the session.gc_maxlifetime value:

    CONFIG_TEXT: session.gc_maxlifetime=86400

  5. Save the changes and close the file.

  6. Open Plesk Services Monitor and restart Plesk Management Service.




 

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.