Applicable to:
- Plesk for Linux
Symptoms
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The installation of a WordPress instance stuck on Downloading and Unpacking:
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The following errors can be found in the
/var/log/plesk/panel.log
with enabled debug:DEBUG [extension/wp-toolkit] Downloading of WordPress 5.4 package will performed at 3 attempts.
DEBUG [extension/wp-toolkit] Start attempt 1 to download package using URL: https://wordpress.org/wordpress-5.4.zip
INFO [extension/wp-toolkit] Acquire lock 'download_package_wordpress-5.4.zip'
Cause
Because of the network issues (WP Toolkit could not download the package due to low speed), the necessary WordPress installation package can not be downloaded.
Here is how it works:
- A task to install a WordPress instance is created, it searches for the package and finds out that it needs to be downloaded from wordpress.org.
- This task tries to download the package. To do it, the task creates a lock file to get the package.
- The task gets stuck forever (or a very long time) because of the network issue.
- A new task tries to download the package and waits for the 1st task to end up so the 2nd one can be locked.
Resolution
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Connect to the server via SSH
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Download the package manually using any method
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Move the package to
/usr/local/psa/var/modules/wp-toolkit/packages/
and changed the ownership to the correct one:# mv wordpress-5.4.zip /usr/local/psa/var/modules/wp-toolkit/packages/wordpress-5.4.zip
# chown psaadm:psaadm /usr/local/psa/var/modules/wp-toolkit/packages/wordpress-5.4.zip
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Remove the "lock" files:
# rm -rf /usr/local/psa/var/modules/wp-toolkit/locks/*
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Connect to the server via RDP
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Download the package manually using any method
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Move the package to %plesk_dir%var\modules\wp-toolkit\packages
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Remove the "lock" files under %plesk_dir%var\modules\wp-toolkit\locks
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