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Receiving Let's Encrypt notifications for a certificate that has already been renewed

Plesk for Linux kb: technical ext: le

Applicable to:

  • Plesk for Linux

Symptoms

  • Let's Encrypt failure notifications arrive for a domain that is actually hosted on a different server.

    Notification

    Could not secure domains of Administrator (login admin) with Let's Encrypt certificates. Please log in to Plesk and secure the domains listed below manually.
    Securing of the following domains has failed:
    <none>
    The following domains have been secured without some of their Subject Alternative Names:
    <none>
    Could not renew Let's Encrypt certificates for Administrator (login admin). Please log in to Plesk and renew the certificates listed below manually.
    Renewal of the following Let's Encrypt certificates has failed:
    'Lets Encrypt certificate' [days to expire: 12] [-] example.com
    Invalid response from https://acme-v02.api.letsencrypt.org/acme/authz-v3/5422301042.
    Details:
    Type: urn:ietf:params:acme:error:unauthorized
    Status: 403
    Detail: Invalid response from https://example.org/.well-known/acme-challenge/QnlaiM9v7msdH9BnqWzyzWx234wJTQjX-7fRot-TqEw [45.91.101.123]: "<html>\r\n<head><title>404 Not Found</title></head>\r\n<body>\r\n<center><h1>404 Not Found</h1></center>\r\n<hr><center>nginx</center>\r\n"
    The following Let's Encrypt certificates have been renewed without some of their Subject Alternative Names:
    <none>
    Legend:
    [+] This domain is secure. The domain's SSL/TLS certificate from Let's Encrypt has been issued/renewed.
    [-] This domain is not secure. Either the domain's SSL/TLS certificate from Let's Encrypt could not be issued/renewed or the domain name was excluded from the certificate. Renew the certificate manually or request a new one to secure this domain.

  • The domain has two certificates.

    • One in the main subscription: Subscriptions > example.com > SSL/TLS Certificates > Advanced Settings
    • Another in Subscriptions > example.com > example.org > SSL/TLS Certificates.

Cause

The notification is for a certificate in the base subscription that is not being used.

Resolution

  1. Log into Plesk

  2. Go to Subscription > example.com > SSL/TLS Certificates > Advanced Settings

  3. Select the unused certificate. Certificates which are in use have a number greater than 0 in the Used column.

  4. Click the Remove button

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