Articles in this section

Unable to send or receive e-mail messages: Hostname is not valid. Please set a hierarchical, dot-separated domain as the hostname

Plesk for Linux kb: technical ext: pes ABT: Group A

Applicable to:

  • Plesk for Linux

Symptoms

  • Unable to send or receive e-mails from remote mail addresses.

  • Customer in Plesk is unable to access Plesk Email Security extension, the following error message is displayed:

    Hostname is not valid. Please set a hierarchical, dot-separated domain as the hostname!

  • The following error messages can be found in /var/log/maillog:

    Nov 12 02:10:38 postfix/error[29408]: BA72F106ECA4: to=johndoe@example.com, relay=none, delay=105489, delays=105488/0.19/0/0.01, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

Cause

The server hostname must be a fully qualified domain name (FQDN). The hostname may either be incorrectly configured in Tools & Settings > Server Settings > Hostname or on the side of the Linux operating system your are using (this can be checked by executing the hostname command when logged into the server terminal).

Resolution

  1. Log into Plesk

  2. Go to Tools & Settings > Server Settings and set a Full hostname.
    If hostname already set, change it to some random one (ex. test.example.com) and then change back to correct hostname. This will trigger the change to /etc/hostname as well.

  3. Open Plesk Email Security in Extensions > My extensions > Plesk Email Security > Open

  4. Click the button Install Now!

Additional information

Server with Plesk Email Security no longer sends/receives emails: [127.0.0.1]:10024: Connection refused

Was this article helpful?

Comments

1 comment
Date Votes
  • I had enabled HSTS, so after changing the hostname I can no longer access Plesk. I am totally locked out.

    0

Please sign in to leave a comment.