Applicable to:
- Plesk for Linux
Symptoms
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Unable to send or receive e-mails from remote mail addresses.
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Customer in Plesk is unable to access Plesk Email Security extension, the following error message is displayed:
Hostname is not valid. Please set a hierarchical, dot-separated domain as the hostname!
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The following error messages can be found in
/var/log/maillog
:hostname postfix/smtpd[36515]: NOQUEUE: reject: RCPT from unknown[203.0.113.2]: 450 4.7.25 Client host rejected: cannot find your hostname, [203.0.113.2]; from=sender@example.net.com to=receiver@example.com proto=ESMTP helo=<info.example.com>
OR
Nov 12 02:10:38 postfix/error[29408]: BA72F106ECA4: to=johndoe@example.com, relay=none, delay=105489, delays=105488/0.19/0/0.01, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Cause
The server hostname must be a fully qualified domain name (FQDN). The hostname may either be incorrectly configured in Tools & Settings > Server Settings > Hostname or on the side of the Linux operating system your are using (this can be checked by executing the hostname
command when logged into the server terminal).
Resolution
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Go to Tools & Settings > Server Settings and set a Full hostname.
If hostname already set, change it to some random one (ex. test.example.com) and then change back to correct hostname. This will trigger the change to/etc/hostname
as well. -
Open Plesk Email Security in Extensions > My extensions > Plesk Email Security > Open
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Click the button Install Now!
Comments
1 comment
I had enabled HSTS, so after changing the hostname I can no longer access Plesk. I am totally locked out.
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