kb: bug
Plesk for Windows
Plesk for Linux
Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
DigitalOcean DNS extension is installed and activated for a domain example.com in Plesk.
-
The domain example.com is not accessible in a browser with:
CONFIG_TEXT: This site can’t be reached
DNS_PROBE_FINISHED_NXDOMAIN -
In the DigitalOcean panel when checking the DNS records for example.com, it can be seen that the
example.com
part is duplicated:CONFIG_TEXT: Type: A
Hostname: example.com.example.com
Cause
Recent changes in DigitalOcean DNS API which led to DigitalOcean DNS extension adding DNS records with the duplicated domain name part.
Such behavior was confirmed as a bug with ID EXTPLESK-3432.
Resolution
Until the new version of the DigitalOcean DNS extension is released, use the workaround:
- Log in to Plesk.
- Go to DigitalOcean DNS menu and press the Deactivate all button to disable the synchronization of DNS zones for all domains.
- Log in to the Digital Ocean panel and adjust the DNS records there manually by removing the duplicated pert in the DNS records' Hostnames.
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