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Can't back up Plesk with Acronis Backup: version `GLIBCXX_3.4.26' not found

Plesk for Linux kb: technical ext: acronis

Applicable to:

  • Plesk for Linux

Symptoms

  • After updating Plesk Obsidian to version 18.0.40, Acronis backup fails with the following error:

    Failed to execute command '/usr/lib/Acronis/BackupAndRecovery/webcpprecapture: /usr/bin/sw-engine: /usr/lib/Acronis/system_libs/8.2.1/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /usr/bin/sw-engine)

  • Acronis console shows the following error message:

    Cannot protect a device with assigned quota
    Protection plan 'webcp' has been revoked from 'server.example.com' due to a licensing issue.

Cause

A bug in the Acronis agent that has been fixed in version 15.0 28610.

Resolution

   
Update the Acronis Agent (Recommended)
   
  1. Log into Plesk

  2. Open Acronis Backup > Go to backup console (it may ask for credentials)

  3. Go to Settings > Agents in the Acronis Backup console

  4. Select the machines with an outdated agent. They're marked with an orange exclamation mark.

    Note: The machines must be online.

  5. Click Update agent

Make sure all previously configured directives are set: 69808: Acronis Backup extension for Plesk: Backup fails after Plesk update to version 18.0.40:

2.png

   
   
Manual Workaround
   
  1. Connect to the server via SSH

  2. Edit /usr/lib/Acronis/BackupAndRecovery/webcpprecapture

    # vi /usr/lib/Acronis/BackupAndRecovery/webcpprecapture

  3. Add the following lines:

    unset LD_LIBRARY_PATH
    unset LD_PRELOAD

  4. Save the changes

If the Acronis agent is on version 28323 (can be checked in Acronis console), follow these steps also:

  1. Connect to the server via SSH

  2. Download the patched libwebcp_agent.so

    # wget https://plesk.zendesk.com/hc/article_attachments/12376927359895/libwebcp_agent.so

  3. Rename the original file:

    # mv /usr/lib/Acronis/BackupAndRecovery/libwebcp_agent.so{,.backup}

  4. Move the downloaded file to the Acronis directory:

    # mv libwebcp_agent.so /usr/lib/Acronis/BackupAndRecovery

  5. Restart the Acronis service:

    # systemctl restart acronis_mms

  6. Verify that Plesk is detected:

    Note: It make take a couple of minutes to take effect.

    # acropsh -m dmldump -s mms -vs InstanceManagement::Instance | grep InstalledApplication

    ('.Parameters.InstalledApplication', 'item_string', 'Plesk'),
    ('.Parameters.InstalledApplication^Searchable', 'nil', None),

   
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