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MSSQL 'sa' user locked out: Login failed for user 'sa'

Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • Database server keeps getting disconnected (the icon is greyed out in Tools & Settings > Database Servers.
  • The following error is shown in the %plesk_dir%admin\logs\php_error.log:

[2018-05-08 15:22:36] ERR [1] "C:\Program Files (x86)\Plesk\admin\bin\mssqlmng" --check "--server=.\MSSQLSERVER2016" "--login=sa" "--password=*****" failed with code 1.
stdout: 
Login failed for user 'sa'. 

  • The sa user is locked out as it can be found in SQL Server Management Studio > Security > Logins > sa > Properties > Status.
  • The sa user keeps getting locked after the unlocking.
  • Unable to create MSSQL databases.

Cause

Password Policy is set to lockout the account after a certain number of failed login attempts.

Resolution

  1. Connect to the server via RDP.
  2. Go to SQL Server Management Studio > Security > Logins > sa > Properties > General and untick the Enforce password policy box.

    Note: Consider restricting IPs for MSSQL

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