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Reseller account do not inherit limits after switching the reseller plan via CLI in Plesk

kb: bug kb: fixed kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

Reseller accounts that are already created do not inherit or apply the limits and permissions defined in their newly assigned reseller service plan (Test_Reseller_Plan) with command:

# plesk bin reseller --update test_reseller_account -service-plan "Test_Reseller_Plan"

Even though the command showed that the mentioned service plan was correctly assigned:

SUCCESS: Update of client 'test_reseller_account' complete.

Cause

Product issue:

  • #PPPM-15007 "Fixed the issue where it was possible to run the plesk bin reseller --update command with the incompatible -service-plan option (which finished successfully, but did nothing)."
    Fixed in:

Resolution

Please consider updating your server:

Workaround

If update is not possible for some reason you may try the following

workaround

The fix for #PPPM-15007 was included in Plesk version 18.0.71.
Update Plesk to the latest build in order to fix the mentioned behavior.

The proper way to switch a reseller account to a different service plan is using the --switch-subscription command as indicated below:

  1. Connect to the server via SSH
  2. Run the following command to switch to a different service plan and get limits/permissions synced with the reseller account:

    # plesk bin reseller --switch-subscription test_reseller_account -service-plan "Test_Reseller_Plan"

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