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In an attempt to log into Plesk or access some pages in Plesk GUI the process is loading forever

Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • In an attempt to log into Plesk or access some pages in Plesk GUI, the pages are loading endlessly and nothing seems to help them finalize loading
  • Restarting Plesk services does not resolve the issue
  • Attempts to resolve the issue via repairs done by the Plesk Reconfigurator are unsuccessful
  • The Windows Event Viewer > Windows Logs > Application log contains many instances of an error that is similar to the following:

    CONFIG_TEXT: The Module DLL C:\Windows\System32\inetsrv\HttpFastCgiModule.dll failed to load.  The data is the error.

Cause

The following unknown malicious modules could be found in IIS > ServerName > Modules IIS modules:

  • HttpFastCgiModule.dll
  • HttpCgiModule.dll

OR

  • UrlRewriteModule.dll
  • FormsAuthenticationModule.dll

OR

  • HttpModule
  • HttpsModule 

Since these modules are not operating correctly, the Plesk web interface cannot load as expected.

Resolution

  1. Log into the server via RDP
  2. Create a backup copy of the C:\Windows\System32\inetsrv\Config\applicationHost.config file via the Windows File Explorer and name it C:\Windows\System32\inetsrv\Config\applicationHost.config.bak
  3. Go to Windows Start Menu > Internet Information Services (IIS) Manager > ServerName > Modules
  4. Remove any mentions of the malicious modules (such as HttpFastCgiModule.dll) from the C:\Windows\System32\inetsrv\Config\applicationHost.config file after opening it with Notepad and save the changes
  5. Run Command Prompt as the Administrator
  6. Restart IIS (in order to to apply the changes) by executing the following command:

    C:\> iisreset /restart

After this has been done, the issue should be resolved.

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