Articles in this section

Not possible to add a new IP address in Plesk on a Cloud-based server: This IP address is not configured properly

Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux

Symptoms

1. Attempting to add an IP address via Plesk > Tools & Settings > IP addresses results into the following error:

PLESK_WARN: This IP address is not configured properly. Repair

2. Clicking repair doesn't resolve the issue and does not report any additional errors as well.

3. A new IP address is not added to the network interface:

# ip a
ens6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
inet 203.0.113.2  netmask 255.255.255.255  broadcast 0.0.0.0
(...)

Note: 203.0.113.2 is an old IP address here.

4. The /etc/netplan/10-plesk.yaml file is configured correctly and contains the new IP address:

# network:
 version: 2
   renderer: networkd
ethernets:
ens6:
 addresses:
   - 203.0.113.1/32

5. The ip addr add 203.0.113.1/32 dev ens6 command doesn't add an IP address to the interface.

6. The plesk bin ipmanage --repair 203.0.113.1 command solves the issue temporarily.

7. The server is cloud-based.

Cause

Cloud servers have different configurations for the network interfaces which are configured in a non-default way (for example, renderer option is set to networkd)

More details can be found here: PPS-17317

Resolution

1. Log into the server via SSH.

2. Adjust the configuration files in /etc/cloud/cloud.cfg.d/99_custom_networking.cfg and /etc/cloud/cloud.cfg.d/99_ionos.cfg so that they have networkd next to the renderer: . In the end, the should looks like this for instance:

CONFIG_TEXT: network:
version: 2
renderer: networkd
ethernets:
all-en:
match:
name: "en*"
dhcp4: true
dhcp6: true

3. Apply the configuration by using this command:

# plesk sbin ifmng -s systemd-networkd

4. If the IP address is not added automatically to the interfaces, try to re-add it once more via Plesk > Tools & Settings > IP Addresses.

Note: The configuration file might differ depending on the cloud provider. Consult cloud provider documentation for more information.

Was this article helpful?

Comments

1 comment
Date Votes
  • If Plesk shows “This IP address is not configured properly,” it means the IP isn’t correctly set on your server. Verify the network settings or contact your cloud provider. Helpful guides and examples can be found on xxbrits.

     

    0

Please sign in to leave a comment.