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Plesk update fails on Windows server: Unable to install exe package vcredist170-XX.XX.XXXXX_x64.exe with error 1603(0x00000643)

Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • Plesk update on Windows Server fails at the Installing packages step.
  • The following error is given in the Plesk interface or within the autoinstaller3.log file:

    CONFIG_TEXT: Installing packages
    Upgrading Microsoft Visual C++ 2015-2022 Redistributable (x64)...
    Unable to install exe package 'C:\ProgramData\Plesk\Installer\cache\pool\release\PLESK-WIN_18.0.XX_XXXXX\thirdparty-windows-x86_64\vcredist170-XX.XX.XXXXX_x64.exe' with error 1603(0x00000643). Output:
    Sub-action 'InstallExe' failed with error code: 1603(0x00000643)

  • Alternatively, the error might explicitly mention another version of the package, such as vcredist180_x64:

    CONFIG_TEXT: Error: The installation of the package 'vcredist180_x64' failed with code 1603. (upgrade: Upgrading Microsoft Visual C++ v14 Redistributable (x64)...)

Cause

A pending system reboot is required by the Windows OS following a previous program installation or Windows update. This pending state prevents the successful installation of the Microsoft Visual C++ Redistributable package.

Resolution

  1. Connect to the server via RDP.
  2. Open File Explorer and navigate to the directory mentioned in the error message. For example:
    C:\ProgramData\Plesk\Installer\cache\pool\release\PLESK-WIN_18.0.XX_XXXXX\thirdparty-windows-x86_64\
    Note: If multiple PLESK-WIN_ folders exist, navigate to the one with the highest Plesk version.
  3. Locate the executable file mentioned in the error (e.g., vcredist170-XX.XX.XXXXX_x64.exe or vcredist180-XX.XX.XXXXX_x64.exe).
  4. Double-click the executable to install the package manually.
  5. Reboot the Windows server to clear the pending state and finalize the package installation.
  6. Log back into Plesk and retry the Plesk update.
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