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Incoming emails are rejected by the local mail server managed Plesk: client host blocked using bl.spamcop.net

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

  • Incoming emails are rejected by the local mail server. Senders receive a bounce back message:

    PLESK_INFO: Message not delivered

    The response from the remote server was:
    554 Transaction failed

  • The following error message is logged in /var/log/maillog:

    CONFIG_TEXT: postfix/smtpd[14842]: NOQUEUE: reject: RCPT from: 554 5.7.1 Service unavailable; Client host [203.0.113.2] blocked using bl.spamcop.net; from=<sender_email> to=<user@example.com>

    CONFIG_TEXT: postfix/smtpd[2329076]: NOQUEUE: reject: RCPT from mail-wr1-f52.google.com[209.85.221.52]: 554 5.7.1 Service unavailable; Client host [209.85.221.52] blocked using bl.0spam.org; Received: from mail-wr1-f52.google.com (mail-wr1-f52.google.com [209.85.221.52])  Fri, 03 Oct 2025 10:42:40 -0700 (PDT) Subject: Re: Minnesota IT Support; from=<user@gmail.com> to=<john_doe@example.com> proto=ESMTP helo=<mail-wr1-f52.google.com>

  • bl.spamcop.net and/or bl.0spam.org blackhole list is enabled in mail settings at Tools & Settings > Mail Server Settings > Spam protection based on DNS blackhole lists.

Cause

Temporary issues on the bl.spamcop.net and/or bl.0spam.org side.

Resolution

  1. Log in to Plesk.
  2. Go to Tools & Settings > Mail Server Settings and scroll down to Spam protection based on DNS blackhole lists.
  3. Remove the malfunctioned DNS blackhole lists from the field:

     

     

  4. Apply the changes.
  5. Optional: Add other DNS blackhole lists, for example, zen.spamhaus.org.
    More blacklists are available at:

     

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