Articles in this section

Cannot install necessary packages for Seafile extension: Python version too old

Plesk for Linux kb: technical ext: kolab

Applicable to:

  • Plesk for Linux

Symptoms

  • On a Plesk server installed on the AlmaLinux 8 operating system, when going to Extensions > My Extensions > Seafile > Open (or Extensions > My Extensions > Plesk Premium Email > Open), the following warning is shown:

    PLESK_WARN: Necessary packages are not installed.

  • When pressing the Install button next to the warning the installation fails with the following error (or without showing any error in the Plesk GUI):

    PLESK_ERROR: Python version too old.

  • Errors that are similar to the following are recorded in the /var/log/plesk/panel.log of the server:

    CONFIG_TEXT: [2026-09-29 13:07:36.458] 2207731:6abb9bf5b4e79 ERR [extension/seafile] Error executing: ;'dnf' '-y' 'install' 'augeas' 'python39' 'python39-setuptools' 'python39-pip' 'python39-devel' 'python39-lxml' 'python3-gunicorn' 'zlib-devel' 'libjpeg-turbo-devel' 'libmemcached-devel' 'gcc' 'gcc-c++' 'wget' 'mariadb-devel'' 
    [2026-09-29 13:07:36.458] 2207731:6abb9bf5b4e79 ERR [extension/seafile] stderr: Error: Problem: package plesk-gems-pre-0.0.1-2.redhat.8+p18.0.75.0+t251107.1216.noarch from @System requires mysql-devel, but none of the providers can be installed - package mysql-devel-8.0.46-1.module_el8.10.0+4192+724bc664.x86_64 from @System conflicts with mariadb-devel provided by mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream - package mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream conflicts with mysql-devel provided by mysql-devel-8.0.46-1.module_el8.10.0+4192+724bc664.x86_64 from @System - package mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream conflicts with mysql-devel provided by mysql-devel-8.0.36-1.module_el8.9.0+3735+82bd6c11.x86_64 from appstream - package mysql-devel-8.0.36-1.module_el8.9.0+3735+82bd6c11.x86_64 from appstream conflicts with mariadb-devel provided by mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream - package mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream conflicts with mysql-devel provided by mysql-devel-8.0.41-1.module_el8.10.0+3965+b415b607.x86_64 from appstream - package mysql-devel-8.0.41-1.module_el8.10.0+3965+b415b607.x86_64 from appstream conflicts with mariadb-devel provided by mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream - package mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream conflicts with mysql-devel provided by mysql-devel-8.0.43-1.module_el8.10.0+4049+06e4dcce.x86_64 from appstream - package mysql-devel-8.0.43-1.module_el8.10.0+4049+06e4dcce.x86_64 from appstream conflicts with mariadb-devel provided by mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream - package mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream conflicts with mysql-devel provided by mysql-devel-8.0.44-1.module_el8.10.0+4079+cc1921b9.x86_64 from appstream - package mysql-devel-8.0.44-1.module_el8.10.0+4079+cc1921b9.x86_64 from appstream conflicts with mariadb-devel provided by mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream - package mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream conflicts with mysql-devel provided by mysql-devel-8.0.45-1.module_el8.10.0+4142+0b28b031.x86_64 from appstream - package mysql-devel-8.0.45-1.module_el8.10.0+4142+0b28b031.x86_64 from appstream conflicts with mariadb-devel provided by mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream - package mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream conflicts with mysql-devel provided by mysql-devel-8.0.46-1.module_el8.10.0+4192+724bc664.x86_64 from appstream - package mysql-devel-8.0.46-1.module_el8.10.0+4192+724bc664.x86_64 from appstream conflicts with mariadb-devel provided by mariadb-devel-3:10.3.39-2.module_el8.10.0+4093+5130acef.x86_64 from appstream - cannot install the best candidate for the job - problem with installed package plesk-gems-pre-0.0.1-2.redhat.8+p18.0.75.0+t251107.1216.noarch - package mysql-devel-8.4.11-1.module_el8.10.0+4255+e01a855c.x86_64 from appstream is filtered out by modular filtering - package mysql-devel-8.4.6-1.module_el8.10.0+4060+d4256e26.x86_64 from appstream is filtered out by modular filtering - package mysql-devel-8.4.7-1.module_el8.10.0+4077+98379720.x86_64 from appstream is filtered out by modular filtering - package mysql-devel-8.4.8-1.module_el8.10.0+4154+a69a9128.x86_64 from appstream is filtered out by modular filtering - package mysql-devel-8.4.9-1.module_el8.10.0+4193+cbb8e728.x86_64 from appstream is filtered out by modular filtering [2026-09-29 13:07:36.463] 2207731:6abb9bf5b4e79 ERR [extension/seafile] Error executing: ;'python3.9' '--version'' [2026-09-29 13:07:36.463] 2207731:6abb9bf5b4e79 ERR [extension/seafile] stderr: bash: python3.9: command not found 
    [2026-09-29 13:07:36.463] 2207731:6abb9bf5b4e79 ERR [panel] PHP Warning: Undefined array key 0; File: /usr/local/psa/admin/plib/modules/seafile/library/Installer.php, Line: 252 
    [2026-09-29 13:07:36.691] 2207731:6abb9bf5b4e79 ERR [panel] Task failed: id=475, pid=2207731, type=ext-seafile-task_install, error=pm_Exception: Python version too old. file: /usr/local/psa/admin/plib/modules/seafile/library/Installer.php line: 261 code: 0 trace: #0 /usr/local/psa/admin/plib/modules/seafile/library/Installer/Centos.php(75): Modules_Seafile_Installer::pipInstall() 
    #1 /usr/local/psa/admin/plib/modules/seafile/library/Task/Install.php(22): Modules_Seafile_Installer_Centos->install(object of type Modules_Seafile_Task_Install) 
    #2 /usr/local/psa/admin/plib/Task/Control/Sdk.php(49): Modules_Seafile_Task_Install->run() 
    #3 /usr/local/psa/admin/plib/Db/Table/Broker/LongTasks.php(178): Plesk\Task\Control\Sdk->run() 
    #4 /usr/local/psa/admin/plib/Db/Table/Broker/LongTasks.php(113): Db_Table_Broker_LongTasks->_syncStart(object of type Db_Table_Row_LongTask) 
    #5 /usr/local/psa/admin/plib/Task/Async/Executor.php(54): Db_Table_Broker_LongTasks->runTaskWithinExecutor(object of type Db_Table_Row_LongTask) 
    #6 /usr/local/psa/admin/plib/scripts/task-async-executor.php(6): Task_Async_Executor->execute() [2026-09-29 13:07:36.692] 2207731:6abb9bf5b4e79 ERR [panel] Python version too old. 
    [2026-09-29 13:07:36.930] 2207731:6abb9bf5b4e79 ERR [panel] Request to ws-server failed with response: 403 Forbidden 
    [2026-09-29 13:07:36.930] 2207731:6abb9bf5b4e79 ERR [panel] Long task executor: id=475 completed with error: Python version too old.: 0: /usr/local/psa/admin/plib/Task/Async/Executor.php:56 Task_Async_Executor->execute() 1: /usr/local/psa/admin/plib/scripts/task-async-executor.php:6

  • The Seafile extension has been installed, but has not been started yet
  • The Installed Python package on the server is python3X, with X being lower than 9:

    # root @ server in ~: yum list installed | grep python3
    ...
    python36.x86_64 3.6.8-39.module_el8.10.0+3769+3838165b @appstream
    python36-devel.x86_64 3.6.8-39.module_el8.10.0+3769+3838165b @appstream

Cause

The currently installed Python package (python3X) is a lower version than Python 3.9.

Seafile requires at least Python 3.9, but does not install the python39 packages, so it fails to set Python version as 3.9, since that version is absent from the server.

Resolution

Until the issue is fixed in a next update of the Seafile extension, you can use the following workaround:

  1. Connect to the server via SSH.
  2. Install the necessary python39-lxml package:

    # yum install python39-lxml

After this package is installed manually, you should go back to Plesk > Extensions > My Extensions > Seafile > Open (or  Plesk > Extensions > My Extensions > Plesk Email Security > Open) and press on the blue Install button once again:

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.