Articles in this section

The Plesk license is getting reset every hour: In order to use Plesk, obtain and install a new trial key.

Plesk for Windows kb: technical

Applicable to:

  • Plesk for Windows

Symptoms

  • Unable to access Plesk, with the following error message appearing within the Plesk GUI:

    In order to use Plesk, obtain and install a new trial key.

  • Installation of a valid purchased activation key works for an hour, then the screen above appears again.
  • The following or similar scheduled events can be found in the Windows Task Scheduler:

    Update Licensing Plesk
    Update Licensing self
    Update Plesk

  • The following .exe files (or similar) can be found in C:\Program Files\ConfigServer\Plesk Licensing System\bin\:

    CSPUpdateV2.exe
    CSPUpdateV2New.exe
    update_plesk.exe

Cause

Third party software (unrelated to Plesk itself) is being used on the server to reset the Plesk license automatically. 

Due to this, any Plesk license you add manually is being removed from the Plesk configuration in a manner that is unrelated to any functions of Plesk.

Resolution

1. Log into your server via RDP
2. Go to Start Menu > Task Scheduler
3. Remove the scheduled tasks that reset the Plesk license

Note: If you are not sure how these scheduled tasks got there in the first place, consult with your system administrator or your server provider, because Plesk itself does not create such license resetting scheduled tasks.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.