Articles in this section

Error when syncing a subscription with a service plan or customizing subscription's resources in Plesk: Unable to allocate the required amount of resources

Plesk for Windows Plesk for Linux kb: technical

Applicable to:

  • Plesk for Linux
  • Plesk for Windows

Symptoms

When synchronizing a subscription with a service plan or customizing subscription's resources at Subscriptions > example.com > Customize, the operation fails with the error message:

PLESK_ERROR: Unable to allocate the required amount of resources

Cause

Database inconsistency: customer that own the subscription has an invalid limits_id value in the Plesk database.

Resolution

  1. Connect to your Plesk server via SSH.
  2. For safety reasons, create a backup of the Plesk database:

    # plesk db dump psa > /root/psa_backup.sql

  3. Find ID of the customer which owns the subscription:

    Note: Replace example.com with a subscription name in the command below: 

    # plesk db "SELECT cl.id AS 'Client ID', cl.pname AS 'Name', cl.login AS 'Login', d.name AS 'Domain' FROM clients cl, domains d, DomainServices ds, IpAddressesCollections ipc, IP_Addresses ip WHERE d.id = ds.dom_id AND d.cl_id = cl.id AND ds.type = 'web' AND ds.ipCollectionId = ipc.ipCollectionId AND ip.id = ipc.ipAddressId AND d.name='example.com'"

    +-----------+----------+----------+-------------+
    | Client ID | Name     | Login    | Domain      |
    +-----------+----------+----------+-------------+
    |        68 | John Doe | john_doe | example.com |
    +-----------+----------+----------+-------------+

  4. Set customer's limits_id to 0:

    # plesk db "update clients set limits_id = 0 where id = 68"

  5. Re-sync the subscription / customize subscription resources.
Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.