Applicable to:
- Plesk for Linux
Symptoms
Tasks in Plesk (e.g. domain creation) get stuck or fail with one of the following error messages:
PLESK_ERROR: Communication with task manager has failed: Bad Request: '{"code":null,"description":null,"message":"CreateTask failed: attempt to write a readonly database (sqlite3.Error)"}
PLESK_ERROR: Communication with task manager has failed: Bad Request: '{"code":null,"description":null,"message":"CreateTask failed: database disk image is malformed (sqlite3.Error)"}
PLESK_ERROR: Cannot connect to the task manager (plesk-task-manager service might not be running): Unable to open named pipe stream: The system cannot find the file specified. (Error code 2) at Unable to connect to pipe \.\pipe\TM_c0b8101d-b5fe-012c-71da-51ef01cac00d<br> at (Con::ClientPipe::create line 189)<br> at (zif_plesk_open_named_pipe_stream line 3000) 0
Additional symptoms on Plesk for Windows Server:
-
Plesk Task Manager Service fails to start in the Services console with:
CONFIG_TEXT: Windows could not start the Plesk Task Manager Service service on Local Computer.
The service did not return an error. This could be an internal Windows error or an internal service error.
If the problem persists, contact your system administrator. -
The following error message may be logged in
%plesk_dir%admin\logs\php_error.log:CONFIG_TEXT: ERR [panel] Unable to find row with id X in longtasks table.:
0: C:\Program Files (x86)\Plesk\admin\plib\Db\Table\Abstract.php:117
Db_Table_Abstract->getOne(string 'X')
1: C:\Program Files (x86)\Plesk\admin\plib\Task\Async\Executor.php:33
Task_Async_Executor->execute()
2: C:\Program Files (x86)\Plesk\admin\plib\scripts\task-async-executor.php:6
Cause
SQLite database db.sqlite3 of Plesk Task Manager is corrupted and can't be opened for editing.
Resolution
Recreate the SQLite database of Plesk Task Manager:
- Connect to your Plesk server via SSH.
-
Stop Plesk Task Manager Service:
# service plesk-task-manager stop
-
For safety reasons, move existing SQLite databases to backup directory
/root/task_manager_dbs:# mkdir /root/old_task_manager_dbs && mv /var/lib/plesk/task-manager/db/* /root/old_task_manager_dbs
-
Start Plesk Task Manager service:
# service plesk-task-manager start
- Log in to Plesk. If notifications about stuck tasks are still displayed in the bottom right corner in Plesk, remove them using the resolution steps from this KB article.
- Connect to your Plesk server via RDP.
- Start a command prompt as an Administrator.
-
Stop Plesk Task Manager service
C:\> net stop PleskTaskManager
- Open
%plesk_dir%var\task-manager\dbin Windows Explorer. -
Delete (move to Recycle Bin) all
db.*files: -
Start Plesk Task Manager service:
C:\> net start PleskTaskManager
- Log in to Plesk. If notifications about stuck tasks are still displayed in the bottom right corner in Plesk, remove them using the steps from this KB article.
Comments
Please sign in to leave a comment.